首页 > 1 软件使用心得, C 个人心得 > 插件冲突,我忙了老半天

插件冲突,我忙了老半天

2010年4月5日 AEROFISH 2,148 views 发表评论 阅读评论

最近有朋友告诉我,我的博客中无法评论,会提示“错误:请输入评论内容。”

经过查找原来是我使用的SyntaxHighlighter Evolved与Quick Comments插件的冲突造成的。

这两款插件一个是代码美化插件,一个是Ajax评论优化插件,都相当的好用。两个作者都使用的是JavaScript代码,他们很可能是使用了相同的函数名或者变量名,导致了在同时使用时,部分功能失效了。

这下好了,碰到了两难问题,我应该舍弃其中一个。

SyntaxHighlighter Evolved插件是我在测试了多款代码美化插件后,决定使用的,至少我目前已经很难找到更好的了。而Quick Comments插件,虽然我只用过这一款评论优化插件,因为它出色的功能,使我从没考虑过用其它的来代替。

最终,考虑了很久还是放弃了Quick Comments。

于是我去网上寻找,找类似能代替的Quick Comments的插件。我知道肯定有类似的好插件存在,但我在搜索引擎上找了大半天,试了好多款评论插件都不太理想。

我就像海底捞针一样,在互联网中寻找,我几乎快绝望了。幸好我还没有放弃,也因为运气好,我在测试了N款评论优化插件后,很偶然的找到了Wordpress Thread Comment这款评论优化插件。可惜作者都1年多不更新了,但功能已经相当的好了,完全不逊色于Quick Comments,我现在博客中使用的就是这款插件。有兴趣的朋友也可以测试下比比看。我忙活了半天终于可以轻松了。

【最后修改时间:2011年1月22日】

本文对我无帮助,减1分本文对我有帮助,加1分 (本文对您有帮助吗?)
Loading ... Loading ...

  1. 2010年4月14日12:35 | #1

    Wordpress Thread Comment有2个缺点,就是首条评论不是Ajax,还有不支持评论修改,可惜作者都不更新,我也不会修改。所以我正在努力学习这方面的知识。

    [嵌套回复]

  2. 求助
    2012年5月27日15:28 | #2

    我也想使用这个带啊名高亮插件,但是无论怎么设置都不生效啊。。。。就是没有样式。。。看出来他识别[/java]代码[/code],但是是一片灰色。

    [嵌套回复]

  3. 瞎扯吧软件
    2012年7月4日22:21 | #3

    Quick Comments与很多插件冲突!

    [嵌套回复]

  1. 本文目前尚无任何 trackbacks 和 pingbacks.